Barracuda: Login Failed Message
Issue
When attempting to login to Barracuda Message Log users may receive the error message:
Login failed. Please contact tech support.
Cause
Barracuda utilizes Microsoft 365 (formerly Office 365) for authenticating users into your email quarantine. This is called Single Sign On (SSO.) SSO permits accounts from different systems and parties to use a unified credential and authentication system. This reduces the need for employees to remember and utilize multiple usernames and passwords within business environments.
SSO works within browsers and apps utilizing sessions, these sessions can expire due to time or condition, requiring users to re-authenticate.
Occasionally Barracuda fails to process the session expiration appropriately and causes the above error to occur when employees attempt to sign on.
Solution
Employees who encounter the above error can follow the below steps to re-authenticate and then login to Barracuda.
- Go to Microsoft365.com using the same browser you are using to access Barracuda.
- Logon to Microsoft365.com, follow any prompts for your username, password and/or MFA authentication.
- After you have successfully logged into Microsoft365.com, go to https://ess.barracudanetworks.com/
- Sign into https://ess.barracudanetworks.com/
You should now be able to access your message log and manage your Barracuda settings.
Additional Troubleshooting
If you are still having issues, try the below steps:
- Clear your browser's cache.
a. How to Clear Microsoft Edge's Cache
b. How to Clear Google Chrome's Cache
- Use a different Web Browser
- Login with a Temporary Password