Barracuda: Invalid Link Error
Issue
When attempting to login to Barracuda users see the below error message:
The link to login is invalid
Cause
This error message is caused by 1 of 2 conditions.
- The User is attempting to login to Barracuda using a link from an old Quarantine notification message.
- Barracuda is having service issues.
Resolution
Regardless of the cause, the solution or workaround for this issue are the same. Users encountering the above should follow the below steps:
- Go to ess.barracudanetworks.com
- Enter your credentials to login.
- After logging in, if you encounter the above message, go to ess.barracudanetworks.com again, without closing the tab or window.
- You should now be logged into the Legacy User Interface of Barracuda, and able to fully manage your Barracuda Message Log.
Additional Troubleshooting
- Clear your browser's cache.
a. How to Clear Microsoft Edge's Cache
b. How to Clear Google Chrome's Cache
- Try another web browser.
- Submit a help desk ticket.